РЕКЛАМА

На главную страницу

РЕКЛАМА




Чтобы разместить ссылку на свой сайт с этой страницы воспользуйтесь системой платных ссылок SAPE.


На главную 1с форева.ру
На страницу "Программисту \ Различные полезные функции, процедуры, куски кода для 1с".

Создать отсутствующие папки из полного пути к файлу в 1с.

Платформа: 8.2, 8.3
Формы: Обычные, Управляемые
Конфигурация: любая
Релиз: любой
Страница актуализирована: 06.02.2017


Процедура создания папок.
При создании нового файла может оказаться так, что каких-то папок из его полного пути нет. Функция позволяет создать эти папки. Она разбирает строку вида "D:\data\bank\20170101\reestr", проверяет наличие всех папок и создает отсутствующие.

Процедура СоздатьНужныеПапки( ПутьКФайлу )

    _Индекс = Найти( ПутьКФайлу, "\" );
    ЛевЧасть = ЛЕВ( ПутьКФайлу, _Индекс );
    ПравЧасть = ПРАВ ( ПутьКФайлу, СтрДлина(ПутьКФайлу)-_Индекс);

    _Индекс = Найти( ПравЧасть, "\" );

    Пока _Индекс <> 0 Цикл

        ИмяКаталога = ЛевЧасть+ ЛЕВ(ПравЧасть,_Индекс);
        КаталогНаДиске = Новый Файл(ИмяКаталога);
        Если НЕ КаталогНаДиске.Существует() Тогда
            СоздатьКаталог(ИмяКаталога);   
        КонецЕсли;    
        ЛевЧасть = ИмяКаталога;
        ПравЧасть = ПРАВ( ПравЧасть, СтрДлина(ПравЧасть)-_Индекс );
        _Индекс = Найти( ПравЧасть, "\" );

    КонецЦикла;   

КонецПроцедуры   



Copyright (c) by iKai, 2016