РЕКЛАМА

На главную страницу

РЕКЛАМА




Чтобы разместить ссылку на свой сайт с этой страницы воспользуйтесь системой платных ссылок SAPE.


На главную 1с форева.ру
На страницу "Программисту \ Разработка (программирование) приложений на платформе 1с".

Операции с файлами и папками в 1с.

Платформа: 8.2, 8.3
Формы: Обычные, Управляемые
Конфигурация: любая
Релиз: любой
Страница актуализирована: 30.01.2017

Шпаргалка по различным операциям с файлами и папками в 1с.

Папки и файлы в 1с.

Диалог выбора файла.
Необходимо добавить реквизит "ИмяФайла"(Строка,Длина неограничена). Добавить на форму элемент с выбором, на его событие "НачалоВыбора" повесить функцию:
ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ДиалогВыбора.Заголовок = "Выберите файл";
ДиалогВыбора.МножественныйВыбор = Ложь;
Если ДиалогВыбора.Выбрать() Тогда
    ИмяФайла = ДиалогВыбора.ПолноеИмяФайла;
КонецЕсли;



Выбор папки. Все тоже самое что и для файла, только код функии "НачалоВыбора" другой.
ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
ДиалогВыбора.Заголовок = "Выберите папку";
Если ДиалогВыбора.Выбрать() Тогда
    ИмяПапки = ДиалогВыбора.Каталог;
КонецЕсли;



Прочесть файлы из каталога по маске.
НайденныеФайлы = НайтиФайлы( _Путь, "*.txt");
Если НайденныеФайлы.Количество()=0 Тогда
    Сообщить(СТРОКА(ТекущаяДата())+" Файлы в папке"+_Путь+" отсутствуют.");
    Возврат 0;
КонецЕсли;
Для каждого ТекФайл Из НайденныеФайлы Цикл
    ...
КонецЦикла;



Проверить есть ли файл. Если нет - создать пустой.
_ИмяФайла = "c:\logfail.log";
Файл = Новый Файл (_ИмяФайла);
Если НЕ Файл.Существует() Тогда
    Текст = Новый ТекстовыйДокумент;
    Текст.Записать(_ИмяФайла);
КонецЕсли;



Удалить все файлы в папке.
Попытка
  УдалитьФайлы("C:\temp\Works");
Исключение
  Сообщить(ОписаниеОшибки());
КонецПопытки;



Копирование файла.
КопироватьФайл(<Полное имя файла источника>, <Полное имя файла приемника>)



Получить атрибуты файла можно при помощи методов объекта Файл. Например получить дату и время последнего изменения файла.
Файл = Новый Файл (_ИмяФайла);
Файл.ПолучитьВремяИзменения();



Полезная функция создающая папки, отсутствующие в полном пути к файлу



Copyright (c) by iKai, 2016